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About Mac Phone

Mac Phone enables you to make VoIP voice and video calls, send and receive 
instant messages, share online status (presence) information, and exchange 
files from your Mac. Mac Phone implements SIP-based standards for phone 
calls, IM and presence, allowing you to work with different VoIP service 
providers.

The Bell Aliant Mac Phone has all standard enterprise telephone features, 
including:

•   call display and Message Waiting Indicator (MWI)

•   speakerphone and mute

•   redial, hold, Do Not Disturb

•   call history – list of received, missed, and dialed calls

•   call forwarding

•   call transfer

•   call record

•   auto answer

• six-party audio conferencing

• three-party video conferencing

Mac Phone also supports the following enhanced features and functions:

• video

• IM and presence using the SIP SIMPLE protocol

• corporate chat rooms.

• contact list containing the individual user’s contacts

• directory containing names from a shared LDAP directory

• automatic detection and configuration of audio and video devices

• acoustic echo cancellation, automatic gain control, voice activity detection

• support for DTMF (RFC 2833 or inband DTMF)
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• support for the following audio codecs: DVI4, DVI4 Wideband, G.711aLaw, 
G.711uLaw, G.722, G.729, GSM, iLBC, L16 PCM Wideband, Speex, Speex FEC, 
Speex Wideband, Speex Wideband FEC

• support for the following video codecs: H.263, H.263+ 1998, H.264

• automatic selection of the best codec based on the other party’s capability, 
the available bandwidth, and network conditions. Mac Phone switches the 
codec within a call in response to changing network conditions.

• integration with a SIP deskphone, so you can use either the deskphone 
controls or the Mac Phone screens to control a phone call.

• Compliance to 3261 SIP standard.

Supported extensions:

— XEP-04

— XEP-016

— XEP-022

— XEP-077

— XEP-085

— XEP-092

— XEP-115

• Support for these firewall traversal solutions: STUN, TURN, or ICE.
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Getting started with Mac Phone

System requirements

Mac Phone requires both speakers and a microphone to make calls. Any of the 
following configurations are acceptable:

• external speakers and microphone

• built-in speakers and microphone

• dual-jack multimedia headset

• USB multimedia headset

• USB phone

Mac Phone is optimized to work with Apple iSight camera.

Launching Mac Phone

1.  Open Mac Phone if it is not already running.

The Mac Phone Login dialog appears with the Profile set to “Manually configure 
login server”.
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2.  Updating your Bria Licence

 When installing and  launching your Mac Phone for the first time, you will   
 require a Bria Mac License in order to complete the upgrade. This information   
 is provided to you by your Bell Aliant Service Representative. This is a onetime   
 requirement, and you will not be asked for this information go-forward. 

 Please note, if you change hardware devices it is important to contact your IT   
 Customer Contact, so they that they can notify Bell Aliant to update records   
 accordingly.

3.  Set the profile to the value specified by your system administrator:

— No login required: Used if you will manually configure Mac Phone, as   
 described below.

— DHCP provided: Used if Mac Phone will be automatically configured 
for you and only if your system administrator has set up for DCHP 
discovery.

— Manually configure login server: Used if Mac Phone will be 
automatically configured for you but you must manually enter the 
server address (as provided by your system administrator).

4. If you chose the DHCP or “Manually configure” profile, the login dialog appears 
for you to enter the login server (“Manually configure” profile only) and your 
credentials. This information is provided by your system administrator.

5. Click Continue.

 The Mac Phone window appears.

Note: After the first-time startup, the Mac Phone Login dialog will not 
appear if you selected the No login required profile.

Note: If you started up the first time with “No login required” but in fact you 
do need to log in, select Preferences, click the Application tab and enable 
login. 
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Configuring your accounts

You must set up your Mac Phone accounts before you can start using the Mac 
Phone. Create your SIP account using the account settings provided by Bell 
Aliant. Optionally, enable the Mac Address Book account to automatically pull 
your Mac Address Book contacts into your Mac Phone contact list so that you 
can easily phone and IM them.

1.  From the menu bar, select Mac Phone > Preferences > Accounts.

The Account list appears with a Mac Address Book account already set up. From 
this window you can create, enable or disable, edit, or remove a SIP or Mac 
Address Book account.

2.   If you want to pull in the contacts from your Mac Address Book, in the list of 
accounts, select the Enabled checkbox next to the Mac Address Book account.

3.   Click the + button and choose New SIP Account.

The SIP Account window opens.

4.  Set up the SIP account using the account information provided by Bell Aliant.
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5.  Optionally, you can also configure the following fields under Voicemail:

— Always forward to this address: To always forward phone calls, click the box 
and enter the address to forward to. Phone calls received on other accounts 
(if you have them) are not affected by enabling this field. This feature works 
only when Mac Phone is running.

— When on the phone, forward to: To forward only when you are on another 
phone call, click the box and enter the address to forward to. Phone calls 
received on other accounts (if you have them) are not affected by enabling 
this field.

6.   When done, click OK.

The account is enabled and registered.

7.   Check the account list to make sure the account registers successfully.

The status of your accounts under the Accounts tab is indicated by the following 
icons:
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  The account is the “preferred account” for the action specified in the column   
 heading.

   The account can be used for phone calls by selecting it on the dashboard    
  (page 7)

•	 The account cannot be used for phone calls.

Setting up a contact list

Typically, you will want to create contacts in order to easily make phone calls, send 
IMs and transfer files. You can bring in contacts from other sources:

• From a file such as a vCard or comma-separated-values (CSV) file. See 
“Populating by importing contacts” on page 40.

• From your Mac Address book. See “Populating from the Mac Address Book” on 
page 38.

• From a corporate directory, if your system administrator has set one up. See   
 “Directory” on page 54.

In addition:

• During a call that you place or receive, you can add the other party to your 
contact list. See “Handling an established call” on page 17.

• You can add addresses to the Contact list one by one. See “Adding a 
contact” on page 42.

For general information on contacts, see “Managing contacts and calls” on page 
36.



10

Navigating the Mac Phone

The Mac Phone menu

The menu contains the following items that are specific to Mac Phone:

Menu item Description

Preferences Manage your Mac Phone preferences. See page .

View Changes how Mac Phone is displayed. Also lets you view message archives 
and chat rooms.

To display a compact view of the Mac Phone, you can hide the dialpad and the 
resources tabs by selecting View > Hide.



11

Contacts Lets you work with contacts.

Menu item Description

Actions Lists the actions that you can perform, depending on the current “state” of Mac 
Phone. For example, if a contact is selected, it lists all the actions that can be 
performed on that contact.

Help Provides access to various service-related features.

The Mac Phone toolbar

The toolbar has various buttons, including the message waiting indicator 
(MWI) and missed calls indicator. Hover over each button for a description.

Receiving an online status request

When you start Mac Phone, one of the first things you may see is an Online Status 
Request dialog. See “Sharing Online Status” on page 46.
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Multimedia communications

Placing a call

To place a call, use one of the options as described in the table below.

Option From the... Description

Keying Dialpad or 
computer 
keyboard

Enter the number or address in the call entry field using the 
Dialpad or the computer keyboard. To turn letters to numbers, 
see “Letters to numbers” on page 14.

If entering a softphone address, you can enter the entire 
address (6045551212@domainA.com) or just the number 
(6045551212).

As you type, a suggestion for completing the entry may appear. 
Choose the suggestion or keep typing.

Click the Call button or press Enter.

Drag-and-drop 
contact or previous 
call

Contacts or History tab Drag an entry from the Contacts or History tab. (If the tab 
contains lots of contacts, first search or filter the list.)

Control-click a con-
tact or previous call

Contacts or History tab Control-click an entry from the Contacts or History tab and 
choose Call or Video Call.

(If the tab contains lots of entries, first search or filter the list.)

Single-click a contact Contacts tab Hover over the right side of the contact to reveal the click-to-call 
button. Click to place a call using the primary phone number for 
this contact.

Redial Redial button When the call entry field is empty, click the Call button.

Or click the arrow in the call entry field and select a recent call. 
An audio call is placed.

Dialing Dialpad If the Dialpad is not visible, click the Show/Hide dialpad button.

Click the numbers on the Dialpad to enter the phone number. 

Click the Call button or press Enter.

From an instant 
message

IM window Click the menu at the top of the IM window and choose Call.
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The outgoing call opens in its own call panel, below any other existing call 
panels. You will hear a ringing tone while Mac Phone attempts to make a 
connection.

Dealing with an auto attendant

If you know that your call will be answered by an auto attendant and you know 
what menu items you will choose, you can include those menu items (DTMF) in 
the phone number when you dial it:

• Before the first DTMF number, include at least one capital P.

• You can include other Ps. Each P causes Mac Phone to wait one second 
before sending the next character.

• At the end of the input, you must include a ; character.

Example: To dial a number, add a 3-second delay and then press 44, enter this in 
the call entry field:

604551212PPP44;
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Example: To dial a number, add a 6-second delay, then press 1 then 3 then 2, each 
with a two second delay:

604551212PPPPPP1PP3PP2;

Selecting the account to use

If you have more than one SIP account set up and enabled, when you place a call,

you can select the account to use for that call. The account must be set up for 
making phone calls. To enable an account to make phone calls, from the menu bar, 
choose Mac Phone > Preferences > Accounts, open the desired account and change 
the Use For fields in the General tab.

When you place a call, you can then explicitly specify the account to use for that 
call.

1.  In the main Mac Phone dashboard, select the down arrow.

2.  Select the account to use.

If you choose Auto Select, the account selected depends on the dial plan rules 
set up by your system administrator. If no dial plan rules exist, the preferred 
account is used.

The account you selected is used for all future calls by default until you 
change this setting.
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Letters to numbers

You can type letters and Mac Phone will convert the letters to numbers when placing the 
call.

1.  Click the Letters to Numbers button  to turn on letters-to-numbers.

2.  Enter the phone number using letters and numbers as desired.

When you click Call, the call panel shows the number in digits.

Hiding your identity (anonymous calling)

To hide your identity on a call, so that the other person will not see your name or 
number on their phone, click the Anonymous Calling button . Your ID will be hidden 
for all outgoing calls until you turn off Hide my number mode.

Anonymous Calling is automatically turned off when you shut down.

Placing another call

You can place another call simultaneously. There is no limit to the number of calls you 
can make, although eventually the quality of audio and video will degrade because of 
limitations on the computer.

1.  While a call is in progress, place another call in the usual way.

Your existing call is put on hold.
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2.  To switch between calls, click Resume on the panel for the call that is on hold.

The call you resume becomes the active call and the other call is placed on hold.

Handling incoming calls

Mac Phone must be running to answer incoming calls. (If Mac Phone is not 
running, incoming calls may be directed to voicemail.)

A new call appears in its own call panel. In addition, the Call Alert box appears, 
even if Mac Phone is minimized. For information on call alerts, see “Alerts and 
sounds” on page 57.

To handle the incoming call, in either the Mac Phone window or the alert window 
that pops up, do one of the following:

• Click Answer. If you are on another call, the first call is put on hold. You are now 
talking to the new caller.

• Click Forward. Enter a name and number to forward the call to.

• Click Decline. The caller receives a busy signal, or the call may be 
forwarded to voicemail.
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• If the incoming call is a video call, click Video to answer and start sending 
video immediately, or click Audio to answer without sending video.

Auto Answer

To set Mac Phone to automatically answer all incoming calls, click the Auto 
Answer button . By default, Auto Answer answers the call after one ring and 
sends audio only when the call is established. To change these settings, select 
Preferences > Call Automation.

Auto answer turns off automatically when you shut down Mac Phone.

Handling an established call

During an active call, you can do the following:

• switch audio controls using the Speakerphone, Microphone, and Mute buttons

• click the Voicemail button to listen to voicemail messages

• place another call (your current call is automatically placed on hold; see 
“Placing another call” on page 15)

• record the call by selecting Start Call Recording
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• send an Instant Message to the caller (see “Sending an IM” on page 23)

• invite the caller to a conference call (see “Starting a conference call from an 
existing call” on page 23)

• if a plus symbol appears beside the caller ID, add the current caller as a contact 
(see “Adding a contact using an existing address” on page 43)

Ending a call

Click the End button on the Call panel (the call can be active or on hold). The call 
panel closes after a few seconds.

Transferring a call

You can transfer a call directly (unattended transfer), or first speak to the person 
you are transferring the call to and then transfer the call (attended transfer).

Transferring a call (unattended)

1.  Click the Transfer button.

The call is placed on hold and a call entry field appears.
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2.  Type a name or number, or drag and drop a contact into the call entry field.

3.  Click Transfer.

The call either ends immediately, or shows the calling progress. If the transfer is 
in progress, do not hang up until the transfer completes. If the transferred call 
is not answered, it is directed back to you.

Transferring a call (attended)

You can first speak to the target (the person you are transferring the call to), then 
click Transfer to complete the transfer.
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1.  Click the Transfer button.

The call is placed on hold and a call entry field 
appears.

Type a name or number, or drag and drop a contact into the call entry field.

2.  Click the down arrow beside Transfer and click Call.

The active call is placed on hold while you are connected to the target 
person to whom you wish to transfer the call.

At any time, you can click Cancel in the call panel for the new call to hang up 
and return to your first call.

3.  Once you are connected with person you want to transfer the call to, when 
ready, do one of the following:
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Click Transfer Now to transfer the call.

Click Cancel if the target does not want to take the call. You are returned to the 
call.

Handling video calls

Placing a video call

Place a video call from the dashboard, your contact list, or call history by 
clicking the down arrow and selecting Video Call.

Optionally, you can option-click the down arrow to set video as the default.

Adding video to an active call

If you have a camera, you can click Start Video to add video to an established call. 
When you add video, the other party may (or may not) start sending their video to 
you.
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Other party adds video

If the other party starts their video, your video panel automatically opens and the 
video is played. You can start sending your own video, if desired (and assuming 
you have a camera) by clicking Start Video on the call panel.

Pausing and resuming video

Click Stop Video on the call panel or close the video window to pause sending 
your video.

Click Start Video to resume sending your video. The video window opens.
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Conference calls

Starting a conference call from the dashboard

1.  Type a number or address, drag and drop a contact or history item, or 
select a contact from the redial list.

2.  Select Start Conference Call.

Starting a conference call from an existing call

To start a conference with a single active caller, select Invite to Conference Call.

To start a conference with multiple active callers, select Merge Calls.
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Adding more participants

You can add more participants to an existing conference in any of these ways:

• Control-click on a contact and choose Add to Conference Call.

• In the conference call panel, enter a name in the call entry field and click Add.

• Add in a separate call that is not part of the conference call: In the call panel 
for the individual call, click the down arrow and choose Merge Calls. This call is 
added to the conference call.

Sending an instant message

Click the down arrow beside a participant name and choose Send Instant Message.

Removing a participant

To remove one call from the conference, click the down arrow beside a participant name 
and choose Separate. The call becomes a separate call.

Ending the conference

To hang up on everyone, click the End button.



25

Suspending the conference

To suspend the conference, click the Hold button. All participants are put on hold.

Starting a conference with video

The conference host (the person who starts the conference) serves as the host for other 
video. Whatever video the conference host is receiving is automatically sent to all the 
other parties. If the conference host pauses or stops video, other participants will no 
longer receive video.

When you start a conference from established calls, video is included if at least one of 
the calls already includes video. When you start a conference from scratch, video is not 
included. You can add video at any time.

To start sending video to all participants, click the Video button. To stop sending video to 
all participants, click the Video button or close your video window.

To start or stop sending video to one participant, click the down arrow beside the 
participant and select Start Video or Stop Video. A status of “Video” appears next to 
each participant to whom you are sending video.
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Voicemail

If you have set up voicemail options, then when you have voicemail messages, 
the voicemail icon appears at the top of the phone (the icon may include a 
number). You can click the icon to automatically connect to voicemail and listen 
to your messages.

See “Configuring your accounts” on page 6 for more information on setting up 
voicemail.

Forwarding calls

You can enable or disable forwarding so that calls will be forwarded to another 
number. You can set up forwarding so that calls are always forwarded or so that 
calls are forwarded only when you are on another call.

Ask your system administrator if you should set up forwarding through Mac 
Phone. It is possible that your system administrator has set up this feature on the 
PBX, so there is no need to set it up in Mac Phone.

To enable forwarding, from the menu bar, choose Mac Phone > Preferences > 
Accounts. Open an account and click the Voicemail tab. For complete details, see 
See “Configuring your accounts” on page 6.
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You can also forward a call on the fly. See “Handling incoming calls” on page 16.

Working in Deskphone Mode

If you have a SIP deskphone, you can use Mac Phone in deskphone mode. In this 
mode:

• You can initiate calls from Mac Phone and then pick up the deskphone 
receiver in order to speak to the person. You can then control the call using 
the deskphone controls. You can also hang up the call using Mac Phone.

• Information about incoming, outgoing and established calls is displayed in  
 MacPhone in read-only mode.

Setting up Deskphone Mode

Before you set up Deskphone Mode:

— Make sure the deskphone has already been set up in your 
network and can make phone calls.

— Find the URI of the deskphone. For example, 3210@myEnterprise.com.

— If you have multiple SIP accounts, the account that the deskphone 
URI belongs to must be the preferred account for phone calls. 
From the menu bar, choose Mac Phone > Preferences > Accounts 
to check which account is the preferred account; change it if 
necessary.

1.  From the menu bar, choose  Mac Phone > Preferences > Devices.

2.  Select the Other Devices tab.

3.  Select Deskphone.

The Deskphone dialog appears.

4.  Enter the deskphone IP address (URI).

mailto:3210@myEnterprise.com
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5.  Click OK.

Placing a call in Deskphone Mode

1.  Click the Deskphone button  to turn on Deskphone Mode.

Note: The Deskphone button is enabled only if you have set up Deskphone

Mode in your preferences.

2.  Place a call in the usual way.

The deskphone rings.

3.  Answer the call on your deskphone.

When the other person answers, the call is established.

You can hang up the call from Mac Phone or from the deskphone.

Answering a call in Deskphone Mode

1.  Click the Deskphone button to turn on Deskphone Mode.

When an incoming call rings, information about the call appears on Mac 
Phone, but you cannot answer the call there.

2.  Answer the call on the deskphone.
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Messaging and sharing

Instant Messaging

Sending an IM

1.  To select a recipient to send an IM to, do one of the following:

From the Contacts tab Control-click on the contact and choose Send IM. The contact must have a softphone 
address.

Or click on the IM icon that appears to the right of the contact name.

An active phone call If the person is a contact, choose Send Instant Message from the call panel menu.

An active conference call If the participant is a contact, choose Send Instant Message from the participant 
menu.

2.  Type the message. Include emoticons and formatting, as desired.

To insert a return in the message, press Ctrl+Enter. (You can control the behavior 
of Enter and of Ctrl+Enter; see “Application” on page 55.)

3.  Press Enter.
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Receiving an IM

When an IM is received, either the IM window or a Call Alert pops up. (To control which 
window appears, from the menu choose Mac Phone > Preferences > Application.)

Sending a broadcast IM

You can send an IM to several people at one time.

Note: A broadcast IM is not a conference IM. With a broadcast IM, each recipient 
can reply to the IM, but only you will see these replies; the other recipients will 
not see these replies. With a conference IM, all parties see everyone’s messages 
and the messages each party sends are seen by everyone. See “Group chat 
(conference IM)” on page 30.

1. Select two or more contacts.

2.    Control-click and select Broadcast Instant Message.

The Broadcast Instant Message window appears.

3.    Type the message. Include emoticons and formatting, as desired.
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4.    Press Send or Enter.

A recipient may send you a response, which will be displayed to you in a regular 
Instant Message window; you will then be in a regular IM with that one party.

Group chat (conference IM)

Group chat allows you to exchange instant messages with a group of people in 
the same session. All people must have XMPP accounts configured in order to 
participate in group chat.

Group chat differs from a broadcast IM in that all parties see everyone’s 
messages, and the messages each party sends are seen by everyone else. In a 
broadcast IM, each recipient can reply to the IM, but only the person who sent 
the broadcast IM will see these replies; the other recipients will not see these 
replies.

There is no limit to the number of participants in a group chat. You can also invite 
more participants during a group chat session.

1.  In the Contacts tab, select the desired contacts.

Note: Contacts must be online.

2.  Control-click the last selected contact and choose Start Group Chat.

The invitation dialog appears.

3.  Change the message, if desired, and click Invite.
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The Group Chat window appears.

4.  To invite more participants, click the + button and select contacts from the list that 
appears.

To remove a participant, click the - button.

Leaving a group chat

To leave group chat, close the group chat window.

If you have started the group chat and you leave the session, the session continues 
with the remaining participants.

Rejoining a group chat

If you leave a group chat, you will be able to rejoin it so long as the session is still 
active (at least one other person is in the chat).

1.  Select View > Chat Rooms.

Even if you do not normally belong to any chatrooms (next page), the 
chatroom popup appears to show you the group chats you had joined that are 
still open.
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2.  Select this group.

The Group Chat window reappears.

Chat rooms

Chat rooms are set up to allow the same group of people to have a group IM 
session, usually on a regular basis. For example, your system administrator may 
create a chat room called “Marketing” and add the marketing staff as members. 
Every Monday at 8:00 a.m., each member opens the chat room on Mac Phone and 
joins the conference.

You can only use chat rooms if your system administrator has set up chat 
rooms and added you as a member. Chat rooms are only available on XMPP 
accounts.

1.  Obtain the names of the chatrooms you belong to from your system administrator.

2.  Choose View > Chat Rooms.

If the menu item does not show, make sure the appropriate SIP account is 
enabled. If you have more than one SIP account, you will also have to select the 
account the chat room belongs to.

3.  Select the appropriate account and click OK.

The list of chat rooms that you belong to appears.
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4.  Select the chat room and click Join Conference. If prompted, enter the pass-
word for the room (obtained from your system administrator).

The Chat Room window appears showing you and other people who have 
already joined to the chat room session.

Viewing the message archive

You can view your recent IM activity for any contact or group chat 
session. Control-click a contact and choose View Message Archive, or 
select View >Message Archive from the menu.
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Sending and receiving files

Sending files

1.  Control-click a contact and choose Send Files.

2.  Select the files to send and click Open.

The Send Files dialog appears with a “waiting” message.

3.  To cancel the file transfer before the other person retrieves the files, click Cancel.
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Receiving files

When another user sends you a file, a window appears prompting you to save the 
file.

Managing contacts and calls

The Contacts tab displays your contacts. Each contact is shown with 
presence information and icons for single-click phoning and instant 
messaging.

If the Contacts tab is not showing, go to the menu bar and choose View > Show 
Contacts.
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You can change the detail and layout of the contact list: from the menu bar choose 
Contacts and set the desired options.

Populating the contact list

At any time, but particularly when you first deploy Mac Phone, you may want 
topopulate the contact list with contacts from an external source.

Populating from an LDAP directory

If your system administrator has set up an LDAP directory, you can create 
contacts from it:

1.  Make sure Mac Phone is configured to connect to this directory (see “Directory”   
on page 54).

2.  From the menu bar choose View > Show Directory.
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3.  From the Directory tab, select people, then right-click and choose Add as 
Contact.

When you have “contacts created from directory”, the contacts are 
automatically updated whenever the corresponding directory entry changes, 
and deleted if the corresponding entry is deleted from the directory.

Populating from the Mac Address Book

You can populate the Mac Phone contact list by pulling in the contacts from your 
Mac Address book.

1.   Ensure that the Mac Address book account that is automatically set up in    
 Mac Phone is enabled. See “Configuring your accounts” on page 6 for more   
 information.

2.  Optionally, if your Mac Address book contains contacts whose presence you  
 can see in your SIP account, modify the contact’s entry in the Mac Address  
 book as follows:

— change Address type to “Phone”

— change Address label to “softphone” (all lower case)
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When you enable the Mac Address Book account in Mac Phone, the contact will be 
pulled in with the specified phone number already set up as a softphone address.

3.  Open the contact and choose the specified phone number in the Presence field.

4.  Click OK.

Mac Phone will obtain availability information for this contact.
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Populating by importing contacts

You can populate the Mac Phone contact list by importing from an external file or files. 
Your system administrator may have placed a file on a server for you to import. You can 
also import your own file or files, as many as required. The new contacts will be added 
to the existing contacts.

Importing from .CSV or vCard files

You can import a contact list from vCard (.*VCF) files or from a Microsoft® Excel® 
comma-separated values (*.CSV) file. To import from a CSV file, you must first set up 
the file. See “Preparing an Excel file for CSV import” on page 40.

1.  From the menu bar, choose Contacts > Import Contacts.

The Import Contacts wizard starts.

2.  Select the file type and file location, and specify whether you want to replace   
     or append to the existing contact list.

Preparing an Excel file for CSV import

1.  Remove any introductory text or headings from the top of the file.

You can keep text at the end of the file; it will be ignored during the import.

2.  Insert a blank row as the first row.

3.  Insert the headings that Mac Phone will use to interpret the meaning of 
each column. The columns can be in any order.

Key headings are sip-address, display-name, given_name, surname, business 
number, and presence_subscription.
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The following table is a list of all the headings used in the Mac Phone contact list.

Heading Description

business_number

business_numbern, where n is 2 to 6

categories Maps to  Mac Phone groups

default_address Maps to the Presence field

default_address_comm Always specifies IM, if default_address is specified. This heading does not 
map to a Contact Profile field

default_address_type SIP

display-name

email_address

email_addressn, where n is 2 to 6

fax_number

fax_numbern, where n is 2 to 6

given_name

home_number

home_numbern, where n is 2 to 6

mobile_number

mobile_numbern, where n is 2 to 6

other_address

other_addressn, where n is 2 to 6

postal_address

presence_subscription If you only want to share presence information with some of your 
contacts, enter “true” for contacts whose online presence you want

to see, leave blank or enter “false” for others. During the import, you will 
be able to choose to share presence with only these contacts. Mac Phone 
will subscribe to the presence of these “true” contacts, assuming that the 
user has a SIP.

If you want to share presence with all your contacts (or with none), ignore 
this heading. During the import you will be able to choose to share with 
all (or none) of your contacts.

sip_address Mac Phone recognizes a value in this column as a softphone address 
and considers the address as one that can be phoned and as an address 
that can be used for IM/presence (if SIP is being used for IM/ presence).

sip_addressn, where n is 2 to 6

surname

web_page

web_pagen, where n is 2 to 6
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4.  Save the file as *.csv.

Exporting contacts

You can export a contact list to a CSV file.

1.  From the menu bar, choose Contacts > Export Contacts.

The Export Contacts wizard starts.

2.  Select the file type and file location for the created file.

A file of the specified type is created.

Adding a contact

1.  Click , or control-click a group and choose Add Contact to Group.

The Contact dialog appears.
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2.  Configure the contact details as follows:

Field Description

Contact Summary

Group Click to show the list of groups. Check each group this contact should belong to.

Primary Call If the contact has more than one number, select the primary number. This number will 
be used with single-click calling.

Primary Presence This field appears only the contact has more than one Softphone number or Instant 
Message address. The primary presence is used as follows:

The presence icon on the contact list shows the online status for this address. The 
single-click action for instant messaging uses this address.

You can still send IMs to this person at their other addresses, but you must right-
click and choose from the context menu.

Other Sections

Display Name (required) The display name for this source of information. For example, the display name from 
the contact list.

First Name, Last Name Optional.

Contact Methods Enter as many contact methods as you want. Enter a person’s IM address as follows:

If you use the SIP account for IM and presence, choose Softphone.

If you have more than one account of a given type, include the domain (for example, 
1440@domainA.com) to ensure that the number or address gets associated with the 
correct account.

Presence This field is automatically populated when you enter an address in the Soft phone or 
Instant Message field. It indicates that you are sharing online presence information 
using this address. The address is also shown in the list in the Primary presence field, 
above.

3.  To enter a phone number, select the phone type, enter the number, and click +.

Adding a contact using an existing address

1.  Do one of the following:

If you are on a phone call with a person who is not a contact, click the Add to 
Contacts icon in the call panel.

On the History tab, select an entry that is not a contact, Control-click, and 
choose Add Contact.



44

The Contact Profile dialog appears.

2.  Complete the dialog as desired and press OK.

If the contact method is Softphone or Instant Message, an online status 
request is sent to this person. See “Sharing online status” on page 46.

Updating contacts from the directory

If you have created a contact created from directory, you can control-click the 
contact and choose Update from Directory in order to bring the latest directory 
information (if any) into the contact. Any key data you had added or changed 
in the contact may be overwritten by the update. Non-key data (such as the 
display name) will not be removed.

Modifying the contact list

Changing contact information

To change the information for a contact, control-click the contact and choose Edit 
Profile. The Contact dialog appears (see “Adding a contact” on page 42).

Moving or deleting a contact

To drag one or more contacts to a different group, select them and drag to the 
title bar of the new group.

To delete one or more contacts, select them, control-click, and choose Delete or 
Delete Selected Items. The contacts are removed from this group. If a contact 
belongs to several groups, it is removed from all groups.
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Adding, deleting or renaming groups

Select any group, control-click, and choose the appropriate menu item.

Contacts that have no group appear under “Ungrouped Contacts.” You can delete, 
but not rename, this group.

Placing a call or sending an IM to a contact

Do one of the following:

Hover your cursor over a name in the contacts panel and click the phone icon or IM 
icon.

Select a name in the contacts list, control-click and select Call, Video Call, or Send 
Instant Message.

Note: If the contact has a SIP address, the contacts panel shows whether 
the contact is available. See “Sharing online status” on page 46.
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Sharing online status

You can publish your online status to contacts who have softphone address, and 
you can set up Mac Phone to view the online status of other contacts. Typical online 
statuses are available, on the phone, or busy.

The online status of your contacts is shown beside the names in your contact 
panel for those contacts to whose online status you are subscribed. Your own 
online status is displayed at the top of the Mac Phone window.

Watching others’ status

To watch a contact’s status, that contact must be tagged for presence:

• If you create a contact using the Contact Profile and you include a SIP 
address in the Softphone field, Mac Phone will automatically obtain status 
information for this address.

• If you created contacts by importing a contact list, you can specify during the 
import whether you want to share presence information. See “Populating by 
importing contacts” on page 40.

• If you enabled the Mac Address Book account in order to pull your Mac 
contacts into Mac Phone, then these contacts will be set up for presence if you 
set up the mapping correctly. See “Populating from the Mac Address Book” on 
page 38.
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When you choose to share presence information, Mac Phone sends the contact 
a notification request. The request asks that you be able to see that person’s 
status. If the person allows this request, then the icon beside their name (in your 
Contacts) becomes color coded to specify their status.

Allowing other parties to see your status (publishing your status)

Continuing from above, when the other person allows the notification request, 
your name is added to their contact list. As soon as you are added to their 
list, a request is sent back to you requesting that they be able to see you. Mac 
Phone accepts this request automatically, and the other person can now see 
your status.

Receiving an online status request

Someone who is not one of your contacts may add you as a contact on their end, 
and may include your SIP address. In this case, Mac Phone receives an online 
status request. The request is handled in one of two ways:

• If you set up a privacy rule before this person has a chance to contact you, 
then you will never see this request. Mac Phone will automatically reply to 
the request according to the rule. See page 56.

• If you do not yet have a privacy rule set up for this person or for their domain,   
 this request appears to you as an Online Status Request. You must respond   
 to the request.
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The table below describes the options for responding to the online status request.

Option Button Comment Result

Create 
a new 
contact

Allow This option is selected for 
you if you do not currently 
have a contact with this 
SIP address.

Allow the request and create a new contact using this 
address.

Because you allow the request, you will no longer be 
bothered by requests from this person. In addition, this same 
request will automatically be sent from your Mac Phone to 
the other person, so that you can see their online status.

Update an 
existing 
contact

Allow This option is selected for 
you if you already have a 
contact with this SIP ad-
dress but you were not pre-
viously sharing your online 
status with this person.

Allow the request and add this address to an existing contact 
(if Mac Phone has found an appropriate match).

Because you allow the request, you will no longer be 
bothered by requests from this person. In addition, this same 
request will automatically be sent from your Mac Phone to 
the other person, so that you can see their online status.

Either 
option

Block Block the request.

This person will not be able to contact you from this 
address.

Either 
option

Ignore Ignore the request.

The other person will not be able to see your online status. 
The other person will not be added to your privacy settings.

The Online Status Request may appear again in this 
session or a future session.

Setting your online status

Click the down arrow beside the online status indicator on Mac Phone, and 
select the desired value.
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The table below describes the online status indicators.

Indicator Meaning for your status Meaning for others’ status

                    Available Either:

• You have set your status to this value.

•  Mac Phone has determined that you are 
logged on but not on the phone or idle.

When you have this status, Mac Phone will 
automatically detect when you are idle or on the 
phone, and change the status to match.

You can contact this person.

                    Busy You have set your status to this value. Mac Phone 
will never automatically switch you out of this 
status; you must switch yourself.

You can contact this person.

                    Away You have set your status to this value. Mac Phone 
will never automatically switch you out of this 
status; you must switch yourself.

You can contact this person.

                    On the    
phone

Either:

• You have set your status to this value. In this 
case, Mac Phone will never automatically 
switch you out of this status; you must switch 
yourself.

• You started a phone call when your status 
was “Available”. When your call finishes, 
your status reverts to “Available”.

You can contact this person.

                    Idle You have not moved or clicked the mouse or 
pressed a keyboard key for the Idle period. To set 
the Idle period see page 55.

As soon as you click the mouse or keyboard, your 
status changes to “Available”.

You can contact this person.

                    Offline You have set your status to this value. The other 
person sees you as offline, even though you are not 
actually offline. The other person cannot tell the 
difference between this status and you really being 
offline.

The contact is either not logged 
on or does not want to share 
online status.

No icon Not applicable You are not watching the other 
person’s online status.

Receiving contact status alerts

You can add a contact to your Alert List in order to request to be notified when the 
online status of a contact changes.

1.  In the contact list, control-click the selected contact or contacts and choose Add 
to Alert List.
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The Alert List icon appears beside the contact.

When the contact’s status changes, a notification appears.

2.  Do one of the following:

If the contact is available, you can click the phone or IM icon to call or 
IM the contact.

Select the Keep Contact on Alert List checkbox to receive another notification 
the next time the contact’s status changes.

Click Close to ignore the status change.

Privacy

You can control how contacts and other people can contact you by phone or IM, 
and you can control whether your contacts can see your availability information 
(whether you are online, one the phone, and so on).

You can set up controls in advance or “on the fly” (as phone calls and presence 
requests come in).
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Setting up controls in advance

To set up controls in advance, see “Privacy” on page 56.

Setting up controls on the fly

From the online status request

Another party can send you a presence request, to request that they be able to 
see your presence, as described in “Receiving an online status request” on page 
47.

Your response has the following effect on privacy:

• If you add the person as a contact, then the ability of that person to phone or   
 IM you is controlled by your privacy settings.

• If you allow the person without adding them as a contact, then the ability 
of that person to phone or IM you is controlled by your privacy settings.

• If you block the person, then that person is added to your Blocked List (Mac   
 Phone > Preferences > Privacy). The person will not be able to phone or IM you,   
 and will not see your availability information. You can change this blocking by   
 removing the person from the Blocked List, in which case they will then be   
 controlled by your privacy settings.

For information on privacy settings and the Blocked List, see “Privacy” on page 56.

From the contact list or history list

Control-click the name and choose Block this Person. The person will be added 
to your Blocked List (see “Privacy” on page 56). The person will not be able to 
phone or IM you, and will not see your availability information.

To later unblock this person, control-click on the name and choose Unblock this 
Person.
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Call history

You can view your call history in the History tab. From the menu bar, choose 
View > Show History.

The Status column indicates incoming missed and answered calls and 
attempted or completed outgoing calls.

Managing the list of calls

Control-click on an entry in the call list to:

• Delete the call.

• Delete all entries in this list.

• Edit the profile if the entry is a contact.

• Add as contact. The Contact dialog appears. See “Adding a contact using an 
existing address” on page 43.

Phoning from the call history

You can control-click on an entry to place a call to this person, using the contact 
method that was used for this call. You can:
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• Control-click on an entry and select Call or Video Call to place a call to this 
person, using the contact method that was used for this call.

• Place a call to this person and add them to a conference call that is in 
progress. For more information on conference calls, see “Conference calls” on 
page 22.

Favorites

To view the Favorites tab, from the menu bar, select View > Show Favorites.

You can create favorites from your contact list. They will be displayed in both the 
contact list and in the Favorites tab. Select the desired contacts, then control-click 
and choose Add to Favorites.

You can perform nearly all the same actions in the Favorites tab as you can 
from your contact list.
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Directory

The Directory tab is available only if your system administrator has set up Mac 
Phone to access a corporate directory.

To view the Directory tab, from the menu bar, select View > Show Directory.

Note: Only one number appears in the directory for each entry. Other 
numbers may appear if you attempt to call the contact.

Placing a call from the directory

Control-click an entry and choose Call or Video Call. The call is placed immediately.

Creating a contact from the directory

1.  Control-click an entry and choose Add to Contacts.

The Contact Profile window appears, populated with all the information from 
the directory (not only the information displayed in the tab).
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2.  Complete the window with any missing information that you want to record.

3.  Click OK.

Note: If the information for a person in the directory ever changes, you 
can control-click the entry and choose Update Contact.

Advanced set-up

From the menu bar, choose Mac Phone > Preferences. The Preferences window 
appears. All the tabs on this window, except for the Accounts tab, configure 
preferences settings.

Application

This panel lets you set your general and login preferences.

Note: Logging in must be enabled for access to your Mac Phone features 
and services. If you selected “No login required” when you launched Mac 
Phone for the first time, select the Enable login screen checkbox, select 
Reset login profile and restart the Mac Phone. When the Mac Phone Login 
dialog appears, select the correct option and log in.
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Privacy

You can control how contacts and other people can contact you by phone or IM, 
and you can control whether your contacts can see your presence information 
(whether you are online, on the phone, and so on).

General tab

For “Global Contact Settings”, choose one option. If you choose “Only people in 
my contact list”, then all contacts will be able to contact you unless their name or 
their domain is in the Blocked list (below).

The “Blocked” section is optional. It lets you enter addresses and domains that will 
be prevented from contacting you.

You can add and remove entries from the blocked lists. In addition, entries are 
automatically added to this list when you block someone on the fly. See “Setting 
up controls on the fly” on page 51.
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Corporate tab

If you enter a domain in this list, people in that domain will automatically be 
allowed to see your online status. You will no longer see Presence Request dialogs 
from these people in this domain.

Alerts and sounds

This panel lets you control the alert box and lets you assign sounds.

Enabling alert displays

You can control whether the Call Alert box is displayed in different situations. 
You can also control how you are alerted to an incoming IM: either with a small 
IM Alert box or with the IM window itself.
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Assigning sounds

You can assign specific sounds to a variety of actions or events. Select the 
Enable sounds check box and select the check boxes for each desired event, 
or clear the Enable sounds check box to disable all sounds.

You can change the sound for each event by selecting individual events.

You can import sounds; these will be added to the list of sounds you can choose 
from when assigning a sound to an event.

Devices

Mac Phone automatically detects devices at each startup, and selects the most 
appropriate device for each purpose. If you do not like this selection, you can 
override it on this panel.

If you override a selection, it will apply the next time you start Mac Phone, 
unless the device is no longer available, in which case Mac Phone will again 
select the device to use.
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The following table describes the fields you can configure in the Devices panel.

Field Description

Headset Mode

Microphone, 
Speaker

Change these fields only if you want to override the devices that  Mac Phone 
automatically selected.

In both these fields, select the headset you are using.

The headset is the device that is usually used for the speaker (the sound you hear) 
and microphone (recording your voice). The only situation in which the headset is 
not used is when the Speaker Phone button on the dialpad is pressed.

Therefore, unless you will always be using Mac Phone in speakerphone mode, 
you must make a selection here.

Select the headset in both the Speaker device field and Microphone device field.

Zero touch device con-

figuration

Typically, leave on. When device configuration is on, if you change your audio or 
video device,  Mac Phone will automatically detect the new device and start using 
it.

Test Devices For information on the Test Devices button, see “Troubleshooting” on page 64.

Speakerphone Mode

Microphone

Speaker

Same as headset mode, but for the device to use when speakerphone is one 
(on the toolbar).

Select None if you do not have a speaker phone. The Speaker Phone button on 
the dial pad will be disabled.

You can set different devices for the speaker and microphone: for example, 
you can set the speaker to the speakerphone and set the microphone to your 
headset.

Other Devices

Ring on The device where you want to hear the phone ringing.

Change this field only if you want to override the devices that  Mac Phone 
automatically

selected.

Volume The volume of the ringer.

Camera This field appears only on versions of  Mac Phone that include video functionality.

Change this field only if you want to override the devices that Mac Phone 
automatically selected.

Select the camera model.

Resolution Leave at standard, or change the size as follows:

Set it to high if you have a good camera and a computer with a fast CPU. You will 
know that you have set the size too large if your computer slows down (the video 
is using too much CPU) or the video shows black areas, or is slow or jerky.

Typically set it to low only in special situations, for example, when using Wi-Fi in a 
hotel. You will know that you have set the size too small if the video is fuzzy.

This field is identical to the Resolution field in Media Quality > Video Quality.

Deskphone Setup If you are set up with a deskphone, click to configure the URI of your deskphone, in 
order to work in deskphone mode. See page 26.
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Network

Select the type of network connection for your computer.

The sliders move to show the bitrate that will be used for sending and receiving. 
These rates are typical rates for the selected configuration.

If you know that your computer and network can handle a faster sending 
speed, click Custom and move the slider. It is recommended that you not 
change the receiving speed.

You will know that you have set the sending speed too high if:

• The remote video shows black areas or is slow or jerky.

• The remote audio is garbled.

You will know that you have set the sending speed too low if the audio is good 
but the video is of poor quality (grainy).

Codecs

Change the settings on this tab only if advised to do so by Bell Aliant
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Media Quality

You can configure audio and video quality preferences in the Media Quality panel.

The following table describes the fields you can configure in the Media Quality 
panel.

Field Description

Audio Quality

Reduce echo Turning this feature on improves sound quality. This feature is typically on.

Reduce background 
noise

Automatically attempts to remove background noise.

Typically on for the speakerphone.

Automatic gain control This feature is typically on.

Preserve bandwidth When this feature is on, Mac Phone stops sending audio when you are not talking.

When this feature is off, Mac Phone always sends audio, which uses more bandwidth but 
may result in better call quality.

Typically off. However, if you are using a slow (dial-up or ISDN) connection, you may 
want to turn it on.

Video Quality

Resolution Leave at standard, or change the size as follows:

Set it to high if you have a good camera and a computer with a fast CPU. You will know that 
you have set the size too large if your computer slows down (the video is using too much 
CPU) or the video shows black areas or is slow or jerky.

Typically set it to low only in special situations, for example, when using Wi-Fi in a hotel. You 
will know that you have set the size too small if the video is fuzzy.

This field is identical to the Resolution field in Devices > Other Devices.
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Call automation

These settings let you configure how you want auto answer to handle incoming 
calls, when Auto Answer is enabled. See “Auto Answer” on page 17.

Directory

Change the settings on this panel only if advised to do so by Bell Aliant.

If your system administrator has instructed you to set the Directory type to LDAP, 
the only feature you should change on your own is Synchronize contacts from 
the directory. See “Populating from an LDAP directory” on page 37.
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Advanced

The following table describes the fields you can configure in the Advanced panel.

Field Description

DTMF Set this field as directed by your system administrator.

RTP Set this field as directed by your system administrator.

Call Recording The folder where files for recording of phone calls will be saved.

File Transfer The folder where received files will be saved.

Web Page Tabs You can set up a web page as a new tab in the Resources panel; it will appear 
alongside Contacts, History and so on.

Enter the web address and a name (this name will be appear in the tab). Enter a 
checkbox to create the tab.

At any time, you can clear the checkbox to remove the tab from the Resources panel.
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Checking for software updates

To check for updates to Mac Phone, from the menu bar, choose Help > Check 
for updates. The Auto Update window appears.

• If a new version of the software is available, you can download it from this   
 window.

• If no newer version is available, this window informs you that your version is 
up to date.

Troubleshooting

Mac Phone includes tools for helping you troubleshoot problems. From the 
menu, choose Help > Troubleshooting. Select one of the following tabs:

• Audio

• Video

• Network

• Devices

• Diagnostics

Testing audio quality

While you are on a phone call, you can test the quality of the audio. Note 
that to perform a valid test, you should be on an established call (not a call 
attempt).
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Testing video quality

While you are on a phone call, you can test the quality of the video. Note 
that to perform a valid test, you should be on an established call (not a call 
attempt).
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Testing the network connection

You can verify that you are successfully connected to the network.

Testing audio devices

You can verify that your microphone and speakers are working and can set the 
volume to a comfortable level without having to actually place a phone call.
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Diagnostics

If requested by Bell Aliant support, you can use the Diagnostics tab to start logging Mac 
Phone activity and send a logging report to Bell Aliant customer support.

1.  Select Diagnostics.

2.  Click Start Logging.

The first Diagnostics Logging window appears.

3.  Select the problem you are experiencing and click Start Logging.

4.  On the second Diagnostics Logging screen, click Finish.
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Logging begins.

5.  Perform the actions you want to capture; for example, attempt to make a phone  
 call.

6.  When done, display the first Diagnostics Logging window again and click Send   
 Report.

A window opens.

7.  Select the report and click Open.

When the report is successfully sent, a confirmation message appears on the 
first Diagnostics window.

8.  Click Stop Logging.

9.  Close the Troubleshooting window.


